View Issue Details

IDProjectCategoryView StatusLast Update
00307032.x IDE BugsGeneralPublic2019-05-08 11:23
ReporterMatthew McInnesAssigned ToRussell Kay 
PriorityVery HighSeverityA - Crash/HangReproducibility50%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030703: General: Crash on startup when using a VPN from an 'unsupported region'
DescriptionISSUE:

- User received a crash on startup, when using a VPN from an 'unsupported region'
- Exception message: Region ID 127 (0x007F) is not a supported region.
Parameter name: culture

EXPECTED:

- IDE should not crash
- A dialog should inform the user that their current VPN configuration is not supported with GMS2
Steps To Reproduce1) Using VPN connect to a US server
2) Launch IDE
3) Observe issue
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/156917
TagsGM2KI, IDE
2.x IDE Found In2.2.2.413
2.x Runtime Found In2.2.2.326
2.x IDE Verified In9.2.1.1805
2.x Runtime Verified In9.9.1.1431

Activities

Matthew McInnes

2019-04-16 16:17

Adminstrator  

ui (2).log (84,627 bytes)

Matthew McInnes

2019-04-17 10:36

Adminstrator   ~0063639

The guy who submitted the ticket was getting this crash with his VPN turned off as well. He could not tell me where he was physically located (which may be the cause of the issue)

Russell Kay

2019-04-17 10:42

Manager   ~0063640

Fixed in github