View Issue Details

IDProjectCategoryView StatusLast Update
0030702RunnerHTML5Public2019-08-19 11:56
ReporterScott DunbarAssigned ToLuke Brown 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.2.2 
Target Version2.2.4Fixed in Version2.2.4 
Summary0030702: HTML5: Inconsistencies with keyboard_* and mouse_* variables between Windows and HTML5 when changing rooms or resetting the game
DescriptionIssue:
Inconsistencies with keyboard_* and mouse_* variables between Windows and HTML5 when changing rooms or resetting the game

Changing Rooms:
 keyboard_* variables are reset on HTML5 but not on windows
 mouse_* variables are NOT reset on either platform (this will need to be checked in development due to a bug fix for : https://bugs.yoyogames.com/view.php?id=30654 )

Game Reset:
 Both keyboard_* and mouse_* variables are reset on windows
 only mouse_* variables are NOT reset on HTML

See attached image (HTML5MK) of a graph to better visualise inconsistency

Expected:
Consistency between both function types and platforms.
Steps To Reproduce1. Import attached project
2. Run project on html5 target
3. Press some keys, and then click the right mouse button
4. Observe after one second the room will change
5. Observe that on room change, the mouse_lastbutton value will not be reset but that all keyboard values have been
6. Press some more keys and click the left or middle mouse button, observe populated information
7. Press escape on the keyboard
8. Observe that mouse_lastbutton is NOT being reset but all the keyboard values are
9. Perform the same tests on Windows and observe the above-noted differences listed in the Description
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In
2.x Runtime Verified In9.9.1.1531

Activities

Scott Dunbar

2019-04-16 16:07

Adminstrator  

HTML5MK.png (5,706 bytes)
HTML5MK.png (5,706 bytes)
keymouse.yyz (32,771 bytes)

Luke Brown

2019-07-16 10:58

Developer   ~0064429

fixed in gitlab