View Issue Details

IDProjectCategoryView StatusLast Update
0030701RunnerFunctionsPublic2019-06-24 12:00
ReporterMatthew McInnesAssigned ToLuke Brown 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030701: Functions: inconsistencies with constants and variables when using real
DescriptionISSUE:

var _a = real(" 0.2 ");
var _b = " 0.2 ";
show_message(_a);
show_message(real(_b));

- Produces an error on line 4

EXPECTED:
- This should not produce an error
Steps To Reproduce1) Launch Beta IDE v2.2.2.412 Runtime v2.2.2.326
2) Import sample project
3) Run project
4) Observe issue
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/156725
TagsCompiler
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In9.9.1.1431

Activities

Matthew McInnes

2019-04-16 14:42

Adminstrator  

RealBug.yyz (20,059 bytes)

Luke Brown

2019-04-17 10:45

Developer   ~0063641

Appears to be a duplicate of issue 0030563. Unable to reproduce the issue on current master so I'm assuming this is resolved.