View Issue Details

IDProjectCategoryView StatusLast Update
0030687RunnerFunctionsPublic2019-05-10 13:00
ReporterYellowAfterlifeAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10 ProOS Version>=1703
Product Version 
Target VersionFixed in Version 
Summary0030687: [Functions] array_get(non-array, _) returns `undefined` instead of throwing an error
Description
show_debug_message(array_get("oh no", 0)); // undefined


Normal (array[index]) array access is unaffected.
Tagsfunctions, Runner
1.4 Found In
2.x Runtime Found In9.9.1.1396
2.x Runtime Verified In9.9.1.1436

Activities

YellowAfterlife

2019-04-15 11:08

Developer  

a_bug.yyz (19,138 bytes)

Russell Kay

2019-04-16 10:23

Manager   ~0063631

this is by design... do you see this as detrimental?

Russell Kay

2019-04-16 14:06

Manager   ~0063634

Fixed in gitlab