View Issue Details

IDProjectCategoryView StatusLast Update
00306482.x IDE BugsGeneralPublic2019-07-11 11:17
ReporterDanAssigned ToDan 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionNo Change Required 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.1 
Target VersionFixed in Version 
Summary0030648: General: Add ui.log entries for passing focus to a game/returning from one so we can detect freezes when closing games
Description We have had a few tickets about GMS2 occasionally freezing when closing a game or a debugger session (which itself closes a game). However, our current ui.log entries do not cover this scenario, so we do not have info to investigate with. We need to add ui.log entries for passing focus to a game/returning from one so we can detect these freezes when closing games.

Expected: Add ui.log entries for launching a game, the stop button being pressed, the debugger session being closed, and (if we can) the runner closing down and GMS2 acknowledging the game has now closed.
Steps To ReproduceN/A
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/155347
Tagsfsd
2.x IDE Found In2.2.1.375
2.x Runtime Found In2.2.1.287
2.x IDE Verified In
2.x Runtime Verified In

Activities

Russell Kay

2019-03-27 14:04

Manager   ~0063552

Not a bug... generate an FSD for this as it is more involved (the Runner is a separate app)

Dan

2019-07-11 11:17

Adminstrator   ~0064398

As above - this should actually all be fixed by the memory corruption fix in 2.2.3 anyway.