View Issue Details

IDProjectCategoryView StatusLast Update
0030637DocumentationManual ContentPublic2019-05-08 15:23
ReporterScott DunbarAssigned ToMark Alexander 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030637: Documentation: ds_priority_find_xxx documentation states that items of equal priority are returned in FIFO order
DescriptionIssue:
The pages of the documentation for ds_priority_find_min/max and ds_priority_delete_min/max, state that: "If more than one value has the same priority, the one that was added to the priority queue first will be the one to get removed...". This is not the case and as per comments from this issue: https://bugs.yoyogames.com/view.php?id=26111 it is not intended to work this way and entries with the same priority have no guaranteed order.



Steps To Reproduce1. Open help documentation
2. Navigate to pages ds_priority_find_min/max and ds_priority_delete_min/max
3. Observe issues in the description
TagsDocumentation

Activities

Scott Dunbar

2019-03-20 09:50

Adminstrator  

ds_priority_.png (10,347 bytes)
ds_priority_.png (10,347 bytes)

Mark Alexander

2019-04-04 09:22

Developer   ~0063583

Docs updated to state that it is impossible to know which one will be returned if two or more items have the same priority.