View Issue Details

IDProjectCategoryView StatusLast Update
0030636RunnerHTML5Public2019-05-08 14:46
ReporterStewart BishopAssigned ToLuke Brown 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030636: HTML5: keyboard_check_pressed fires every step, seems to be releasing the key
DescriptionPreviously if you called keyboard_check_pressed in a step event this would fire once and then be in the held state but now it seems to be releasing the key and firing the press event every step, this was tested in Chrome and Firefox.
Steps To Reproduce1) Run the sample on Windows
2) Press and hold space
3) Run the sample on HTML5
4) Press and hold space
5) See the difference
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.2.321
2.x Runtime Verified In9.9.1.1431

Activities

Stewart Bishop

2019-03-20 09:49

Adminstrator  

Press_Test.yyz (46,558 bytes)

Luke Brown

2019-04-05 14:41

Developer   ~0063593

fixed in gitlab - issue was caused by fix to issue 0029735 (https://bugs.yoyogames.com/view.php?id=29735) which still appears to function as expected.