View Issue Details

IDProjectCategoryView StatusLast Update
00306262.x IDE BugsBuild UbuntuPublic2019-05-23 11:06
ReporterStewart BishopAssigned ToRussell Kay 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ResolvedResolutionFixed 
PlatformUbuntuOSOS Version
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030626: Build Ubuntu: [ERROR] FATAL UNHANDLED EXCEPTION: System.NotSupportedException: Key 'OPENSSH' is not supported.
DescriptionWe've had a report that from the Mac IDE it's not possible to run or build an executable for Ubuntu. The user is presented with this error:

[ERROR] FATAL UNHANDLED EXCEPTION: System.NotSupportedException: Key 'OPENSSH' is not supported.

We should investigate why this is happening and fix it or update our guides.
Steps To Reproduce1. Have a fresh Mojave install which has never had ssh keys generated by GMS2 on it.
2. Start the Mac IDE
3. Target Ubuntu and try to build.
4. Observe the error as described.
Repro: 100% on fresh-install machines
Tagsigor, mac
2.x IDE Found In2.2.2.404
2.x Runtime Found In2.2.2.317
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2019-05-20 16:34

Adminstrator   ~0063951

Last edited: 2019-05-20 16:37

View 2 revisions

The cause was identified when we eventually reproduced it on a machine here. It's that Mojave has changed ssh settings and so the new keys a fresh OS install user would get don't work with our tools. Added repro steps.

Have now fixed GMS2 for 2.2.3 to make the key tool always generate keys in the format we're expecting - the runtimes will also flush keys which have this issue and create fixed new ones the first time it encounters this issue, avoiding the user seeing this error once they update to 2.2.3.