View Issue Details

IDProjectCategoryView StatusLast Update
0030624RunneriOSPublic2019-05-08 15:28
ReporterStewart BishopAssigned ToCoreTech 
PriorityHighSeverityC - GeneralReproducibilityUnable To Reproduce
Status ClosedResolutionFixed 
PlatformiOSOSiOSOS Version
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030624: iOS: Virtual key touch doesn't work when virtual key touches the edge of the screen
DescriptionWe've had some users put in tickets saying that virtual keys which touch the portrait edge of the screen don't register touches for a small buffer at the top and bottom of the device unless they do a multi touch with one finger much more central on the screen.

There is a GMC discussion about this here: https://forum.yoyogames.com/index.php?threads/ios-problem-with-touch-delay-on-the-bottom-of-the-screen.60518/ and apparently it's a source of negative feedback for these devs' games.

We've tested this using multiple different iOS devices with samples which touch the edges of the screen and simply cannot reproduce using our devices, but we should investigate it anyway on the devices that are mentioned as having the issue, namely any SE device. We have not been able to reproduce on a couple of iPhone 7 devices, despite this being one stated as giving this issue by a dev on that GMC page.

https://discussions.apple.com/thread/8072780 this thread was also found, which pointed to SE devices having issues with touches when the devices were new, but Apple have since released an update that fixes this. Anyone who has this issue needs to ensure their iOS version is above the one stated on this thread (and up-to-date) and then retest.
Steps To Reproduce1) Run the sample
2) Touch the 4 buttons, ensuring you touch the very edges of the screen
3) Observe whether for the top and bottom vkeys a touch is always detected correctly, or if you need to use two fingers on the screen in order for the vkey to always work correctly. (The left and right ones are apparently not affected by this issue.)
Tagsios, Runner
1.4 Found In
2.x Runtime Found In2.2.2.317
2.x Runtime Verified In9.9.1.1431

Activities

Stewart Bishop

2019-03-14 10:40

Adminstrator  

Problem_VK_KeyDown_iOS.yyz (87,542 bytes)