View Issue Details

IDProjectCategoryView StatusLast Update
00306202.x IDE BugsGeneralPublic2019-06-18 17:19
ReporterStewart BishopAssigned ToAlexander Borup 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030620: General: IDE runs at 60 FPS max regardless of your monitor's refresh rate
DescriptionTesting this on my 180 Hz refresh rate monitor if I show the FPS within the IDE it'll only ever max out at 60, if I drag it to either of my 60 Hz monitors then it'll give me the same refresh rate. Seems like we're always syncing and never using the refresh rate of the monitor.
Steps To Reproduce1) Open the IDE on a high refresh rate monitor
2) Show the FPS within the IDE
3) See that it's capped at 60 FPS rather than whatever your monitors refresh rate is
TagsIDE
2.x IDE Found In2.2.2.402
2.x Runtime Found In2.2.2.315
2.x IDE Verified In9.2.1.1817
2.x Runtime Verified In9.9.1.1441

Activities

Russell Kay

2019-03-14 09:52

Manager   ~0063499

We should consider a preference on the cap for frame rate (what is the top frame rate we allow in the IDE refresh)

Alexander Borup

2019-04-09 13:37

Developer   ~0063599

Put an FPS cap preference in range 30-9999 that you can change, with a default FPS of 60 (power consumption balance). It doesn't fit to the monitor's refresh rate because this'll be based on the monitor it launched on, which will probably cause more issues than it'll solve... So if you have a 144Hz monitor you use GMS2 on, you can set the FPS to 144... odds are you won't be hitting that framerate very often, though; the GUI framework is not particularly performant. Fortunately I did an optimization years ago that makes panning workspaces as cheap as it'll get, so at least for panning workspaces, code editors and other fullscreen editors it'll work nicely...