View Issue Details

IDProjectCategoryView StatusLast Update
00306182.x IDE BugsBuild iOSPublic2019-06-25 15:04
ReporterMark AlexanderAssigned ToFritz 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformiOSOSOS Version
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030618: iOS Build: GMS2 always fails to run project on device due to i386 architecture error during Tests phase
DescriptionWhen test building for iOS, the game is not being run on the chosen device, and you are required to use the Xcode play button to start it. All devices are correctly detected in the GMS target manager, and "suppress build and run" is unchecked. I've found this for all simulated devices, and Stewart has said that it happens to him for physical devices too.

The error I get is:

ld: entry point (_main) undefined. for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)


Testing failed:
    linker command failed with exit code 1 (use -v to see invocation)
    Testing cancelled because the build failed.
** TEST FAILED **


The following build commands failed:
    Ld /Users/Nocturne/Library/Developer/Xcode/DerivedData/NinjaLeap_iOS-ezlmfyilmxxohucuvvydfhxogtcb/Build/Intermediates.noindex/NinjaLeap_iOS.build/Release-iphonesimulator/NinjaLeap_iOS.build/Objects-normal/i386/NinjaLeap_iOS normal i386
(1 failure)
Igor complete.

Expected behaviour is that testing a project in GMS with a selected device will run the project on that device.
Steps To Reproduce1. Run any project for iOS.
2. Observe it errors during the Tests phase and so doesn't launch properly on the device.
3. (Optional) Run the game via Xcode instead and observe this works fine.
Repro: 100%
TagsGM2KI, igor
2.x IDE Found In2.2.2.401
2.x Runtime Found In2.2.2.314
2.x IDE Verified In2.2.3.429
2.x Runtime Verified In2.2.3.340

Activities

Dan

2019-06-24 10:45

Adminstrator   ~0064243

Runtime 339+

Dan

2019-06-25 15:04

Adminstrator   ~0064282

Launches my game first time on a real device, now, so Closing.