View Issue Details

IDProjectCategoryView StatusLast Update
0030596RunnerHTML5Public2019-05-08 15:39
ReporterStewart BishopAssigned ToAntanas Budvytis 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030596: HTML5: Modified Variable Definitions do not copy over with room_duplicate
DescriptionIf you create an instance in a room, set a variable definition to be something different than the default and then duplicate the room, on Windows this will work as expected however on HTML5 this will not work and uses the default value.
Steps To Reproduce1) Import the sample
2) Open rm_test
3) Set the variable for obj_test to be true
4) Run it on Windows, see that the object rotates
5) Run it on HTML5, see that the object doesn't rotate
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.2.312
2.x Runtime Verified In9.9.1.1431

Activities

Stewart Bishop

2019-03-07 10:41

Adminstrator  

var_def_bug_html.yyz (20,766 bytes)

Antanas Budvytis

2019-04-10 17:09

Developer   ~0063607

Issue was caused by instance pre-creation code not being copied when duplicating room storage entries.