View Issue Details

IDProjectCategoryView StatusLast Update
0030585RunnerWindowsPublic2019-05-08 15:53
ReporterStewart BishopAssigned ToMike Rennie 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10OS Version
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030585: Windows: Texture groups with "allow scaling" disabled still apply texture_global_scale() value
DescriptionWithin the sample project, the 2nd and 4th sprite are part of texture groups with "allow scaling" disabled. On Windows, texture_global_scale() still scales them in-game, however on macOS texture_global_scale() has no effect, as expected.

Expected: You can't scale textures marked as not allowing scaling.
Steps To Reproduce1) Open the project in GMS2
2) Run the project on Windows and observe the textures scale
3) Run the project on macOS and observe the textures do not scale
Repro: 100%
TagsRunner
1.4 Found In
2.x Runtime Found In2.2.2.312
2.x Runtime Verified In9.9.1.1431

Activities

Stewart Bishop

2019-03-04 17:44

Adminstrator  

ScaleSample.yyz (132,492 bytes)

Russell Kay

2019-03-05 09:36

Manager   ~0063431

The "allow scaling" bit is not a bug - but we should look at the macOS vs Windows differences

Mike Rennie

2019-04-11 12:06

Developer   ~0063609

The Windows runner now respects the Allow Scaling option in the same fashion as the macOS runner.