View Issue Details

IDProjectCategoryView StatusLast Update
00305582.x IDE BugsGeneralPublic2021-07-19 11:59
ReporterDanAssigned ToCoreTech 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionSuspended 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.2 
Target VersionFixed in Version 
Summary0030558: General: IME window is not positioned next to where you're typing - always in bottom-right of "highest" screen
DescriptionThe IME window is not positioned next to where you're typing when using GMS2. Instead, its always in the bottom-right corner of your "highest" screen (so if you have 2 monitors, it's off on screen 2, etc.). Looks like we don't calculate a location value at all and so Windows just dumps it there.

Expected: The IME window should float just below where you're typing, so then you can see the suggestions and click them very easily. It should at the very least be on the same monitor that GMS2 is on.
Steps To Reproduce1. Install another language in Windows - e.g. Simplified Chinese - and switch to this.
2. Start GMS2 and create a new project.
3a. Open Preferences > Object Editor. Type some text and observe the IME window opens on your second monitor.
3b. Open the Code Editor via an object/script/timeline. Type some text and observe the IME window opens on your second monitor.
Repro: 100%
TagsNo tags attached.
2.x IDE Found In2.2.2.393
2.x Runtime Found In2.2.2.308
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2019-02-22 17:50

Adminstrator  

IMEWindowOffset.png (756,642 bytes)

SamH

2021-07-19 11:59

Developer   ~0066408

Unable to confirm now, as missing required device. If this still happens in the current GMS2 release, then we will investigate a fresh report. Closing.