View Issue Details

IDProjectCategoryView StatusLast Update
00305562.x IDE BugsBuild iOSPublic2019-03-04 13:47
ReporterDanAssigned ToRussell Kay 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformiOS VMOSmacOS MojaveOS VersionPro x64
Product Version2.2.0 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030556: Build iOS: VM does not set the launch images correctly in the asset catalog, so splash screens don't load
DescriptioniOS VM does not add all the launch images required by the asset catalog, so splash screens don't load on some devices.

You can see this in detail if you open the launch images section for the project in Xcode (as shown in the screenshots attached):

Doesn't use either of the XS_max or XR portrait screens that we have added for 2.2.2 - the two landscapes are there, but no portraits.
All 4 "iPad without Status Bar iOS 5/6" screens are not set.
There is also an unexpected extra screen added but Unassigned - presumably due to a typo in the build script, as you can see the name has a "_ipn" typo in it.
Steps To Reproduce1. Start GMS2 and create a new project / open any project.
2. Ensure all iOS splash screens and icons are set - FYI 0030547.
3. Run it for iOS VM.
4. When the project has opened on Xcode, open the Launch Images section.
5. Observe the launch screens issues described above.
Repro: 100% - FYI I am building using the Windows IDE and targeting qa4kimac, which has the latest Xcode on it.
TagsNo tags attached.
2.x IDE Found In2.2.0.343
2.x Runtime Found In2.2.0.261
2.x IDE Verified In2.2.2.397
2.x Runtime Verified In2.2.2.311

Relationships

related to 0030546 ClosedRussell Kay Build iOS: YYC does not set the launch images correctly in the asset catalog, so splash screens don't load 

Activities

Dan

2019-02-22 14:50

Adminstrator  

VM1.png (254,149 bytes)
VM1.png (254,149 bytes)
VM2.png (242,842 bytes)
VM2.png (242,842 bytes)

Russell Kay

2019-02-26 11:17

Manager   ~0063334

Fixed in gitlab and github

Dan

2019-02-26 11:23

Adminstrator   ~0063336

Last edited: 2019-02-26 11:23

View 2 revisions

IDE 395+ / Runtime 310+

Scott Dunbar

2019-03-04 13:47

Adminstrator   ~0063419

Verified fixed. Closing

IDE 2.2.2.397
Runtime 2.2.2.311