View Issue Details

IDProjectCategoryView StatusLast Update
00305462.x IDE BugsBuild iOSPublic2019-03-04 13:48
ReporterDanAssigned ToRussell Kay 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformiOS YYCOSmacOS MojaveOS Version
Product Version2.2.0 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030546: Build iOS: YYC does not set the launch images correctly in the asset catalog, so splash screens don't load
DescriptioniOS YYC does not set the launch images as "assigned" in the asset catalog, so splash screens don't load. Each splash screen entry actually has an error that that individual splash has 23 unassigned children - not sure if this isn't a badly-worded Xcode error, though.

You can see this in detail if you open the launch images section for the project in Xcode (as shown in the screenshot attached):

We are failing to add iPad iOS 7+ images to the asset catalog properly - these images are actually in the "unassigned" list below, so this just seems to be that the template project does not use the correct entries?
All other images are loaded, but you can see that every one of them is marked with a warning that the image is not actually set properly in the catalog.
YYC doesn't use the XS_max_portrait screen that we have added for 2.2.2 - landscape is there, but no portrait.
The two "Default..." images have plain black placeholders - this is because they are not in game options or the base project at all (so the user has no way to set these), and we must be giving these black placeholders as part of the build script.
Steps To Reproduce1. Start GMS2 and create a new project / open any project.
2. Ensure all iOS splash screens and icons are set - FYI 0030547.
3. Run it for iOS YYC.
4. When the project has opened on Xcode, open the Launch Images section.
5. Observe all the launch screens have the relevant issue described above.
Repro: 100% - FYI I am building using the Windows IDE and targeting qa4kimac, which has the latest Xcode on it.
Tagsigor
2.x IDE Found In2.2.0.343
2.x Runtime Found In2.2.0.261
2.x IDE Verified In2.2.2.397
2.x Runtime Verified In2.2.2.311

Relationships

related to 0030556 ClosedRussell Kay Build iOS: VM does not set the launch images correctly in the asset catalog, so splash screens don't load 

Activities

Dan

2019-02-21 14:29

Adminstrator  

iOSLaunchScreensBroken.png (535,959 bytes)

Dan

2019-02-21 17:01

Adminstrator   ~0063279

Attached a sample with fixed splash screens to get around 0030547

testIOSScreens.yyz (64,472 bytes)

Russell Kay

2019-02-22 14:23

Manager   ~0063295

Fixed in gitlab

Dan

2019-02-26 11:23

Adminstrator   ~0063335

Last edited: 2019-02-26 11:24

View 2 revisions

IDE 395+ / Runtime 310+

Scott Dunbar

2019-03-04 13:48

Adminstrator   ~0063420

Verified fixed. Closing

IDE 2.2.2.397
Runtime 2.2.2.311