View Issue Details

IDProjectCategoryView StatusLast Update
0030541RunnerSpinePublic2019-05-08 16:00
ReporterStewart BishopAssigned ToMike Rennie 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionWon't Fix 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030541: Spine: Issue with track mixing
DescriptionWithin the sample when mixing between the crouching animation and the standing animation this used to work in 2.2.1 but doesn't correctly in 2.2.2 this seems to be caused by skeleton_animation_clear() as commenting out the line with this fixes the issue.
Steps To Reproduce1) Run the sample
2) Hold S or Down
3) Release it
4) See that the mix doesn't work
5) Comment out line 37 in objPlayer > Step
6) Perform 1-3 again
7) See that this now works
TagsRunner, Spine
1.4 Found In
2.x Runtime Found In2.2.2.308
2.x Runtime Verified In9.9.1.1431

Activities

Stewart Bishop

2019-02-20 12:42

Adminstrator  

Spinebug2.yyz (77,029 bytes)

Russell Kay

2019-02-27 09:50

Manager   ~0063359

We think this is caused by a change in Spine itself and not something we need to fix, but we're investigating the inner workings a bit further here, just in case it exposes something.

Mike Rennie

2019-02-27 09:53

Developer   ~0063360

It's difficult to determine if the behaviour shown here is an actual bug - this sample 'fails' in the same way in 2.2.1 so it's not something that's occurred as a result of the Spine upgrade.

If there has been a behavioural change it would be useful to get a sample that shows different behaviour in 2.2.1 and 2.2.2 to help us isolate the problem, as whatever is going on is in the internals of the Spine runtime code and not apparently to do with the integration with GameMaker.

Mike Rennie

2019-04-11 10:30

Developer   ~0063608

The sample does the same thing in version 2.2.1 as well so the behaviour hasn't changed due to the spine upgrade. After further investigation it does seem that this is how the spine runtime treats this particular combination of animations.