View Issue Details

IDProjectCategoryView StatusLast Update
00305362.x IDE BugsBuild MacPublic2019-02-27 17:44
ReporterStewart BishopAssigned ToRussell Kay 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformmacOSOSOS Version
Product Version2.2.2 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030536: Build Mac: Creating an executable with an incomplete extension macro definition doesn't stop build with an error
DescriptionIf you create an extension and within a placeholder resource, add a macro and don't give it a value, then when creating an executable for macOS this will continue the build process indefinitely (usually - very occasionally, an exception for a timeout will be seen).

This is because the application oven has an error about reading beyond the index range, but doesn't return this info to the IDE.
Steps To Reproduce1) Open the sample project
2) Create an executable for Mac VM
3) See that this fails
4) Open the extension, add in a value for the macro
5) Create an executable again
6) See that this works
Tagsigor
2.x IDE Found In2.2.2.393
2.x Runtime Found In2.2.2.308
2.x IDE Verified In2.2.2.396
2.x Runtime Verified In2.2.2.311

Activities

Stewart Bishop

2019-02-18 16:21

Adminstrator  

MacroExtHangIssue.yyz (15,516 bytes)

Russell Kay

2019-02-19 20:12

Manager   ~0063253

Unable to reproduce on Red...

Dan

2019-02-25 16:16

Adminstrator   ~0063328

Last edited: 2019-02-25 16:37

View 2 revisions

Red doesn't hang ("hang" was an incorrect choice of words anyway, as at no point does the IDE go unresponsive, so have removed it from the description above), but it does occasionally come back with an error and then the build stops:

Renci.SshNet.Common.SshOperationTimeoutException: Session operation has timed out
   at Renci.SshNet.Session.WaitOnHandle(WaitHandle waitHandle, TimeSpan timeout)
   at Renci.SshNet.Session.WaitOnHandle(WaitHandle waitHandle)
   at Renci.SshNet.Session.Connect()
   at Renci.SshNet.BaseClient.Connect()
   at Igor.RealSSH.pscp(String local, String remote, Boolean recursive)
   at Igor.MacUtils.InstallRunnerOnMac(String workingFolder, String outputFolder, String remote_install_path)
   at Igor.MacBuilder.Package()
Igor complete.

It doesn't tell us what the issue is / where to go looking to fix it, so I imagine this would still result in a support ticket being sent to us.

Russell Kay

2019-02-26 11:48

Manager   ~0063341

Fixed in gitlab

Dan

2019-02-26 16:00

Adminstrator   ~0063350

Runtime 311+

Matthew McInnes

2019-02-27 17:44

Adminstrator   ~0063379

Closing. Verified as fixed in:

IDE v2.2.2.396 Runtime v2.2.2.311