View Issue Details

IDProjectCategoryView StatusLast Update
00305332.x IDE BugsImage EditorPublic2019-05-15 14:53
ReporterDanAssigned ToAlan Savage 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.1 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030533: Image Editor: Eraser tool can partially restore content which has been deleted with backspace
DescriptionUsing the Image Editor and swapping between frames when you have an active selection, you can see that the Eraser tool can partially restore content which has been previously deleted with backspace. It cannot full restore the content, so you end up with garbled information, as shown in the screenshot.

I cannot reproduce without having multiple frames and changing between them whilst your selection area is active - which is the repro given in the original ticket also.
Steps To Reproduce1. Start GMS2 and create a new project.
2. Create a new sprite, then open it for editing in the Image Editor.
3. Add a second frame and select this new second frame for editing.
4. Draw anything on the second frame, then use the selection tool to select around it.
5. Now select frame 1, then back to frame 2. Click within your section area to toggle focus back to the editor without losing your selection area.
6. Backspace.
7. Now select the eraser and go over the area you just deleted, and watch as parts of it come back.
Repro: 100%
TagsIDE, ImageEditor
2.x IDE Found In2.2.1.375
2.x Runtime Found In2.2.1.287
2.x IDE Verified In9.2.1.1817
2.x Runtime Verified In9.9.1.1441

Activities