View Issue Details

IDProjectCategoryView StatusLast Update
00305112.x IDE BugsSyntax ErrorsPublic2019-02-27 14:57
ReporterMark AlexanderAssigned ToRussell Kay 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030511: Syntax Checker: Specific typo has missing error message, shows exception in tooltip
DescriptionWhile typing some code in a project I got flagged with a syntax error. Going to the line, at first glance I couldn't see what was wrong, and so moused over the error (!) in the gutter and got a huge error message shown to me that looks like it's broken - as if the proper message couldn't be found?

Steps To ReproduceI've added a YYZ that shows the issue, but it's easy to reproduce:

var _xx = 1000;
_xx = _xx += _x;

Note the typo with += instead of just +. Mouse over the error to get the broken message.
TagsCodeEditor, IDE
2.x IDE Found In2.2.2.393
2.x Runtime Found In2.2.2.308
2.x IDE Verified In2.2.2.396
2.x Runtime Verified In2.2.2.311

Activities

Mark Alexander

2019-02-12 10:22

Developer  

Syntax_Error.yyz (19,594 bytes)

Dan

2019-02-18 11:48

Adminstrator  

SyntaxErrrorMissing.png (21,062 bytes)
SyntaxErrrorMissing.png (21,062 bytes)

Russell Kay

2019-02-20 13:50

Manager   ~0063266

Fixed in github

Dan

2019-02-22 10:46

Adminstrator   ~0063285

IDE 394+

Scott Dunbar

2019-02-27 14:57

Adminstrator   ~0063368

Verifed fixed. Closing

IDE: 2.2.2.396 Runtime 2.2.2.311