View Issue Details

IDProjectCategoryView StatusLast Update
0030441RunnerMacPublic2021-04-20 14:51
ReporterStewart BishopAssigned ToMike Rennie 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionDuplicate 
PlatformmacOSOSmacOS MojaveOS Version
Product Version2.2.1 
Target VersionFixed in Version 
Summary0030441: Mac: Frameskipping using draw_enable_drawevent() leaves ghost images
DescriptionWithin the users sample they rotate a sprite which on Windows leaves no ghost images but on Mac it leaves ghost images of the previous frames.

When you run the sample on macOS the game will flash constantly until you press Space which disables frame skipping but once frame skipping is enabled again the ghosting happens.
Steps To Reproduce1) Run the sample on Windows
2) Use Space to turn frame skipping on and off to see the differences
3) Run the sample on macOS
4) See the flashing
5) Press space twice
6) See that you now get ghosting
Additional InformationJust to note, the user also stated that this happened on Ubuntu too, but I was unable to reproduce so it's potentially that we've fixed that platform already or it's hardware/driver-dependant.
Tagsmac, Runner
1.4 Found In
2.x Runtime Found In2.2.2.296
2.x Runtime Verified In

Activities

Stewart Bishop

2019-01-23 10:38

Developer  

Frameskip Test.yyz (534,493 bytes)

Alice

2021-04-20 14:51

Adminstrator   ~0065676

Moved to Jira as per Scott's comment. Closing the bug. Thank you.