View Issue Details

IDProjectCategoryView StatusLast Update
00304382.x IDE BugsCode EditorPublic2019-01-30 09:46
ReporterDanAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030438: Code Editor: "Invalid token" error for DnD nodes generates duplicate/confusing entries
DescriptionAs you can see from the attached screenshot, there is an unwanted ' added to the DnD node show. However, what I get for compiling is 3 errors - 2 of them duplicates for the wrong event. Initially, I thought this user's project had been corrupted, as the compile log describes the "invalid tokens" as it builds, but on seeing their project I realised it was an easy mistake. However, the compiler errors confused the issue for me for a minute, and I suspect are the reason this new user reported the ticket in the first place.

Expected: One compile error, which also lists the token causing the issue, e.g. "Object: obj_gangster Collision Event With obj_fanthehammer at line 7 : invalid token ' "
TagsCompiler
2.x IDE Found In2.2.1.375
2.x Runtime Found In2.2.1.287
2.x IDE Verified In2.2.2.389
2.x Runtime Verified In2.2.2.302

Activities

Dan

2019-01-23 09:34

Adminstrator  

Dan

2019-01-24 14:13

Adminstrator   ~0062506

Oddly, if you attempt to clean the project after running it, you will get an extra duplicate of the obj_player invalid token every time you clean (so you get 4, 5, 6... errors).

dnderrors.yyz (34,883 bytes)

Russell Kay

2019-01-25 14:37

Manager   ~0062514

Fixed in gitlab

Dan

2019-01-30 09:46

Adminstrator   ~0062571

All good now - only the one error and it says what the invalid token is. The issue with cleaning has been fixed also.