View Issue Details

IDProjectCategoryView StatusLast Update
00304152.x IDE BugsBuild MacPublic2019-05-16 12:04
ReporterDanAssigned ToSteven Campbell 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformmacOSOSWindows 10OS VersionPro x64
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030415: Build Mac: El Capitan is not compatible with the updated ffmpeg in 2.2.1, breaks building and running games
DescriptionEl Capitan is not compatible with the updated ffmpeg in 2.2.1, which breaks building and running games because any audio files in the game are not able to be converted/played.

Note that whilst we only state support for Sierra and above on the system requirements page, there are a number of users using GMS2 on El Capitan and we're getting tickets about this, so it would be good to investigate if this is fixable.
Steps To Reproduce1. Try to build a project which contains audio files on El Capitan.
2. Observe your build will complain about not being able to convert your audio files.
Repro: 100%
TagsNo tags attached.
2.x IDE Found In2.2.1.375
2.x Runtime Found In2.2.1.287
2.x IDE Verified In2.2.2.390
2.x Runtime Verified In2.2.1.291

Activities

Dan

2019-01-11 15:19

Adminstrator   ~0062438

Xcode does not contain El Cap support in current versions, so ffmpeg was not being built with El Cap support.

Matthew McInnes

2019-01-31 17:20

Adminstrator   ~0062622

Closing. Verified as fixed in:

Beta IDE v2.2.2.390 Runtime v2.2.1.291