View Issue Details

IDProjectCategoryView StatusLast Update
0030370RunnerHTML5Public2019-01-29 12:22
ReporterStewart BishopAssigned ToMike Rennie 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030370: HTML5: Layer begin/end scripts are not called during the Draw event
DescriptionWithin this project the user calls shader_set inside a layer begin script and shader_reset inside a layer end script. On Windows this will use the shader correctly but on HTML5 this doesn't work.
Steps To Reproduce1) Run the sample on Windows
2) Run the sample on HTML5
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.2.293
2.x Runtime Verified In2.2.2.302

Activities

Stewart Bishop

2019-01-07 14:06

Adminstrator  

HTMLTEST.zip (45,288 bytes)

Mike Rennie

2019-01-17 16:23

Developer   ~0062465

The problem wasn't anything to do with shaders but just that the layer begin\end scripts weren't getting called during the draw event. This has now been fixed.