View Issue Details

IDProjectCategoryView StatusLast Update
00303632.x IDE BugsBuild HTML5Public2019-01-29 14:07
ReporterMatthew McInnesAssigned ToAlan Savage 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030363: HTML5: WebGL detection is broken for Opera browser
DescriptionISSUE:

- We have broken WebGL detection when using Opera - setting your game to "require" HTML5 will stop it loading, telling you WebGL is not supported, and running with "auto-detect" shows that WebGL is not in use.
- Potentially related to / caused by https://bugs.yoyogames.com/view.php?id=28712

EXPECTED:

- Should detect properly whether WebGL is supported or not
Steps To Reproduce1) Launch GMS2
2) Load attached sample project
3) Ensure WebGL is set to 'auto detect' or 'required'
4) Run attached project for HTML5 with Opera as the selected browser
5) Observe issue
Additional Information IDE v2.2.1.375 Runtime v2.2.1.287
TagsNo tags attached.
2.x IDE Found In2.2.1.375
2.x Runtime Found In2.2.1.287
2.x IDE Verified In2.2.2.38
2.x Runtime Verified In2.2.2.302

Activities

Matthew McInnes

2019-01-04 17:14

Adminstrator  

WebGLTest.yyz (19,825 bytes)

Matthew McInnes

2019-01-29 14:07

Adminstrator   ~0062551

Closing. Verified as fixed in:

IDE v2.2.2.387 Runtime v2.2.2.302