View Issue Details

IDProjectCategoryView StatusLast Update
0030344RunneriOSPublic2018-12-19 10:50
ReporterDanAssigned ToAntanas Budvytis 
PriorityVery HighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
PlatformiOSOSiOSOS Version9 and older
Product Version2.2.1 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030344: iOS: iOS 9 and older crash on game startup because of iPhone X home bar functionality
DescriptionGames run on iOS 9 and older devices crash on game startup because of iPhone X home bar functionality we introduced in 2.2.1. This home bar functionality needs to confirm the OS version in use on the device and only work on applicable iOS versions.

2018-12-14 19:02:06.118 WordWowSeasons[3773:9888981] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[RunnerViewController setNeedsUpdateOfScreenEdgesDeferringSystemGestures]: unrecognized selector sent to instance 0x17e20860'

*** First throw call stack:

(0x2461f91b 0x23dbae17 0x246252b5 0x24622ee1 0x2454e238 0x182b6d 0x2904ed2b 0x290509d1 0x28e3c231 0x28c0f445 0x28e3b14b 0x28e4f83d 0x28e387b3 0x25cc2c07 0x25cc2ab9 0x25cc2db9 0x245e1dff 0x245e19ed 0x245dfd5b 0x2452f229 0x2452f015 0x28c08c3d 0x28c03189 0x24e65b 0x241d7873)

libc++abi.dylib: terminating with uncaught exception of type NSException


This issue is also being discussed on the GMC: https://forum.yoyogames.com/index.php?threads/nsinvalidargumentexception-error-on-xcode-9-4-1.56514/
Steps To Reproduce1. Run a game built using GMS2 2.2.1.287 on an iOS 9 device.
2. Observe game fails to start and Xcode on the Mac will say the above if you read the device's logs.
Additional InformationNote that current versions of Xcode only build for iOS 10+, so you need an older Xcode install in order to reproduce/verify.
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.1.287
2.x Runtime Verified In2.2.1.290

Activities

Dan

2018-12-18 16:18

Adminstrator   ~0062296

Will be in runtime 290+

Dan

2018-12-19 10:50

Adminstrator   ~0062303

Stewart showed me all is good in 290. Closing.