View Issue Details

IDProjectCategoryView StatusLast Update
0030342RunnerGeneralPublic2018-12-19 10:49
ReporterYellowAfterlifeAssigned ToRussell Kay 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindows YYCOSWindows 10 ProOS Version>=1703
Product Version2.2.1 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030342: General: Recursive function calls now return undefined on YYC platforms
DescriptionThis works fine in 2.2.0, but was broken for 2.2.1.

scr_test:
if (argument0 == 0) {
    var v = 0; // must have any preceding action to reproduce
    return scr_test(1);
} else return "ok!";


and then:
show_debug_message(scr_test(0));


Windows: ok!
Windows (YYC): undefined
Steps To ReproduceThis works fine in 2.2.0, but was broken for 2.2.1.

scr_test:
if (argument0 == 0) {
    var v = 0; // must have any preceding action to reproduce
    return scr_test(1);
} else return "ok!";


and then:
show_debug_message(scr_test(0));


Windows: ok!
Windows (YYC): undefined
Additional InformationTakes 40 minutes to strip a malfunctioning JSON decoder to the cause being literally just this, btw
TagsCompiler, yyc
1.4 Found In
2.x Runtime Found In2.2.1.287
2.x Runtime Verified In2.2.1.290

Activities

Russell Kay

2018-12-18 14:22

Manager   ~0062288

Fixed in gitlab

Dan

2018-12-18 14:24

Adminstrator   ~0062289

Cleaned the sample, added the repro steps.

yycrecursivebug.yyz (21,445 bytes)

Dan

2018-12-18 14:25

Adminstrator   ~0062290

Fix is in runtime 290+

Dan

2018-12-19 10:49

Adminstrator   ~0062302

All good in 290. Closing.