View Issue Details

IDProjectCategoryView StatusLast Update
0030333RunnerFunctionsPublic2019-01-30 16:07
ReporterYellowAfterlifeAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10 ProOS Version>=1703
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030333: Functions: `var arg=argument;` is allowed and is remarkably inconsistent
DescriptionGML:
var arg = argument;
trace("arg is " + string(arg));


Native VM:
Throws "illegal access of argument, argument is not provided to script" but also retrieves the value of argument0 on it's way out

Native YYC:
Does not compile - throws "error: expected expression" because the generated code is literally
local_arg=;


HTML5:
Accesses g_pBuiltIn.argument, which is not a thing

I think the right thing to do would be to forbid index-less references to `argument` entirely until it can become a real array.
TagsCompiler, functions, yyc
1.4 Found In
2.x Runtime Found In9.9.1.1280
2.x Runtime Verified In2.2.2.302

Activities

YellowAfterlife

2018-12-13 23:35

Developer  

a_bug.yyz (48,045 bytes)

Russell Kay

2018-12-17 14:43

Manager   ~0062278

Fixed in gitlab