View Issue Details

IDProjectCategoryView StatusLast Update
0030316RunnerFontPublic2019-01-30 14:18
ReporterDanAssigned ToMike Rennie 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030316: Font: font_add_sprite_ext() separator calculation seems to be +1 in 2.2.1 compared to 2.2.0 and older
DescriptionWhen adding a new font in-game via font_add_sprite_ext() you can see the separator calculation seems to be +1 in 2.2.1 compared to 2.2.0 and older. So, e.g., for a separator of 0 you still have padding.

You can see this in the attached screenshots and sample.
Steps To Reproduce1. Run the attached sample for Windows/HTML5.
2. Observe it looks like the 221 screenshot, not the 220.
Repro: 100%
TagsFont, Runner
1.4 Found In
2.x Runtime Found In2.2.1.287
2.x Runtime Verified In2.2.2.302

Activities

Dan

2018-12-12 10:40

Adminstrator  

220.png (6,274 bytes)
220.png (6,274 bytes)
221.png (6,897 bytes)
221.png (6,897 bytes)
proportional_font.yyz (41,323 bytes)

Mike Rennie

2018-12-20 11:02

Developer   ~0062311

Fixed in gitlab