View Issue Details

IDProjectCategoryView StatusLast Update
00303152.x IDE BugsGame OptionsPublic2019-01-30 15:06
ReporterDanAssigned ToSteven Campbell 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030315: Game Options: Android: SDK dropdown should set API levels 28+ "Minimum SDK" as 16, not 14
DescriptionGame Options > Android's SDK dropdown should set API levels 28+ "Minimum SDK" as 16, not 14. 14 is too low for what the current APIs require, so users currently always have to fix this value.

It might also be worth setting the Build Tools to be 28.0.3 at this time, as this version has been out for a while, and is one fewer thing for the user to have to change.


!! The same change(s) should be made for Amazon Fire's version of this gadget also if the two aren't linked !!
Steps To Reproduce1. Start GMS2 and create/open any project.
2. Options > Android > General, click the dropdown for "Pre-populate SDK values...".
3. Pick API Level 28 (or higher if you have them).
4. Observe GMS2 will set the "Minimum SDK" as 14.
Repro: 100%
Tagsandroid, IDE, thatsit
2.x IDE Found In2.2.1.375
2.x Runtime Found In2.2.1.287
2.x IDE Verified In2.2.2.390
2.x Runtime Verified In2.2.2.302

Activities

Steven Campbell

2018-12-13 16:08

Manager   ~0062236

Fixed in Red IDE/GitHub Pull Request 4400
Git Id: 98318e9ac5ba4fb15744d8181c5d37af63f91da3

Matthew McInnes

2019-01-30 15:06

Adminstrator   ~0062592

Closing. Verified as fixed in:

IDE v2.2.2.390 Runtime v2.2.2.302