View Issue Details

IDProjectCategoryView StatusLast Update
00303112.x IDE BugsSavingPublic2019-02-14 12:39
ReporterStewart BishopAssigned ToAlexander Borup 
PriorityVery HighSeverityB - MajorReproducibility<25%
Status ClosedResolutionFixed 
Product Version2.2.1 
Target Version2.2.1Fixed in Version2.2.2 
Summary0030311: Saving: Whilst the debugger is open sometimes the project will throw a project save error if you create a new resource
DescriptionAt least twice a day currently whilst the debugger is open if I create a new script then I'll get an error which says the project.yyp couldn't be saved. I've never seen any issues but I wouldn't be surprised if I lose work one day.

The ui.log has the following snippet:

[11:46:41:566(48ae)] Error, can't delete file before moving for file C:\Source\IDE\Studio2\Projects\testFramework\testFramework.yyp. Exception "The process cannot access the file 'C:\Source\IDE\Studio2\Projects\testFramework\testFramework.yyp' because it is being used by another process."
[11:46:41:567(48ae)] File exception 'The process cannot access the file 'C:\Source\IDE\Studio2\Projects\testFramework\testFramework.yyp' because it is being used by another process.'
[11:46:41:627(48ae)] SourceControlAction:SaveModel: The process cannot access the file 'C:\Source\IDE\Studio2\Projects\testFramework\testFramework.yyp' because it is being used by another process.
Steps To Reproduce!) Open a project
2) Debug it
3) Close the game so the debugger is open
4) Whilst the debugger is open and not attached to your game create a script
5) 25% of the time this will throw a project saving error
TagsIDE
2.x IDE Found In9.2.1.1643
2.x Runtime Found In9.9.1.1278
2.x IDE Verified In2.2.2.393
2.x Runtime Verified In2.2.2.308

Relationships

has duplicate 0028796 ClosedAlexander Borup Saving: IDE occasionally locks files from itself on save 

Activities

Alexander Borup

2018-12-14 10:05

Developer   ~0062239

The debugger invokes the asset compiler, which kept a stream to the file open for all eternity in this particular code path.

Dan

2018-12-17 11:26

Adminstrator   ~0062268

Fix is now in runtime 288+.

Matthew McInnes

2019-02-14 12:39

Developer   ~0063204

Closing. Verified as fixed in:

Beta IDE v2.2.2.393 Beta Runtime v2.2.2.308