View Issue Details

IDProjectCategoryView StatusLast Update
0030287RunnerFunctionsPublic2021-08-04 15:14
ReporterYellowAfterlifeAssigned ToCoreTech 
PriorityLowSeverityD - MinorReproducibility100%
Status ResolvedResolutionFixed 
PlatformWindowsOSWindows 10 ProOS Version>=1703
Product Version2.2.1 
Target VersionFixed in Version 
Summary0030287: Functions: variable_instance_ functions work on global built-in variables
DescriptionThrough a recent peculiar mishap it came to my attention that variable_instance_ functions also lookup built-ins for some reason
trace("argument0:", variable_instance_get(self, "argument0"))
trace("argument_count?", variable_instance_exists(self, "argument_count"))
variable_instance_set(self, "room_speed", 45);
trace("room_speed:", variable_instance_get(self, "room_speed"))
trace("keyboard_string:", variable_instance_get(self, "keyboard_string"))
trace("view_current:", variable_instance_get(self, "view_current"))
trace("application_surface:", variable_instance_get(self, "application_surface"))
//trace(variable_instance_get(self, "argument")) // but not this one :c

While this is mildly entertaining, the number of such variables is relatively small and it might be better to get rid of this for performance and consistency with HTML5
Additional InformationPotentially the root cause of https://bugs.yoyogames.com/view.php?id=30130
Tagsfunctions
1.4 Found In
2.x Runtime Found In9.9.1.1263
2.x Runtime Verified In

Activities

YellowAfterlife

2018-12-05 10:43

Viewer  

a_bug.yyz (48,182 bytes)

SamH

2021-08-04 15:14

Developer   ~0066628

No longer reproduces in v2.3.3. Closing.