View Issue Details

IDProjectCategoryView StatusLast Update
00302712.x IDE BugsGeneralPublic2019-06-25 15:24
ReporterAlexander BorupAssigned ToAlexander Borup 
PriorityVery HighSeverityA - Crash/HangReproducibility<25%
Status ClosedResolutionFixed 
PlatformOSWindows 10OS Version
Product Version2.2.1 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030271: General: Windows deadlock issue (dead Explorer instances and white screens for browser pages)
DescriptionThis is just to have a single report on the Windows deadlock issue, aka the Explorer file dialog stall previously reported in 0026316. This is a problem that can occur when talking with other processes.

These scenarios are all (likely) the same issue:
- Opening CEF can show a white screen as it fails to load a website (Marketplace / Manual / My Account)
- Stopping a running game can hang GMS2
- Opening a file dialog can hang GMS2 (Open/import/Save/Save As dialogs)
- Entering a GMS2 window context with an OS drag and drop package can hang Explorer (not GMS2)
- Crash/hang when trying to open the release notes pages from the Help menu
- Launching a run of your project can hang GMS2 with the tooltip showing for the run/debug button
- Calling the IME input window and typing text in that window.

For example, if CEF shows a white screen and fails to load any site then opening a file dialog will fail.
If dragging a file inside GMS2's window and Explorer hangs, opening a file dialog - or CEF, or stopping a game - will likewise fail.
Steps To Reproduce1. Create a macro that will launch GMS2 and...
1a. Open a file dialog - see eventual deadlock
1b. Open the Marketplace (CEF) - when a white screen is shown (and the page fails to load indefinitely), see that opening a file dialog will deadlock
... and so on
TagsGM2KI, IDE
2.x IDE Found In2.2.1
2.x Runtime Found In
2.x IDE Verified In
2.x Runtime Verified In

Relationships

parent of 0026769 ClosedAlexander Borup Compiling: IDE can stall when a build is stopped, causing high CPU usage and must close via Task Manager 

Activities

Dan

2019-05-10 12:30

Adminstrator   ~0063890

We have been working with Microsoft on this for the last few weeks, and have now found an issue we can address.

Alexander Borup

2019-05-10 14:28

Developer   ~0063892

I believe I have fixed the issue.

Dan

2019-06-25 15:24

Adminstrator   ~0064285

These startup crashes / IDE crashes when opening external processes are all fixed by the change for 0030271. In the month or so since this change was made, we have not seen these issues - and 2.2.3 beta period is so far saying the same thing. Regardless, all of these would now be covered by the new crash-reporting system, so these issues will not be reopened even if we do have reports of crashes still occurring. New reports using the memory dumps will be made instead.

Closing!!!!!!!!!!!!!! (This feels great! ;) )

IDE v2.2.3.429 Runtime v2.2.3.340