View Issue Details

IDProjectCategoryView StatusLast Update
00302702.x IDE BugsMarketplacePublic2019-01-31 15:50
ReporterAlexander BorupAssigned ToAlexander Borup 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030270: Marketplace: Cannot access private assets in My Library
DescriptionPrivate assets cannot be accessed in My Library, despite having been added to the account.

This breaks the flow in My Library were you can see updates to your assets and download and import them.
Steps To Reproduce1. Add a private asset to your account on the Marketplace website via link.
2. See that it will not show up in My Library.
Tagsweb
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.2.390
2.x Runtime Verified In2.2.2.302

Activities

Alexander Borup

2018-12-17 09:40

Developer   ~0062258

Last edited: 2018-12-17 09:52

View 2 revisions

The private asset appears twice in the marketplace extensions list we get from the server. It contains first a non-hidden version, and then the identical asset again but with "hidden" set to true. They are completely identical assets - this is the only difference. Under Purchase History the asset is set to "Show in library".

Dan

2019-01-04 12:22

Adminstrator   ~0062339

Last edited: 2019-01-31 15:48

View 3 revisions

Alex did actually add an IDE-side workaround for this website bug at the time he added his above comment, but this only covers the case in which a developer has two or more instances of the asset and one of them is public and the other(s) not. Have added the SHA info and marking the report as Resolved.

I have now added a web bug to get the root issue fixed for all scenarios - https://yoyogames.atlassian.net/browse/WB-202


If you can't see your own publisher's Marketplace assets, this is because you currently need to "purchase" the asset on its Marketplace page. Once you have done this, refresh your Manifest in My Library and the asset will appear.

Dan

2019-01-31 15:50

Adminstrator   ~0062612

Private assets do show fine now, so Closing (although note my comment above that if you're the publisher and you can't see your own assets it's because you need to "purchase" it manually).