View Issue Details

IDProjectCategoryView StatusLast Update
0030266RunnerAndroidPublic2019-10-09 11:24
ReporterDanAssigned ToFritz 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionUnable To Reproduce 
PlatformAndroidOSOS Version
Product Version2.2.0 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030266: Android: Runner doesn't support Samsung Galaxy S8/S9 extended screen size option, gains black bars
DescriptionWe have a couple of reports that the runner doesn't support the Samsung Galaxy S8/S8+/S9/S9+'s extended screen size option and instead always uses 1920x1080. 1920x1080 is the default value the device ships with. However, there is a "High Resolution" system setting which can be turned on to increase this to 2960x1440 when running specified apps. At which time the game is drawn with black bars along the top/bottom edges of the phone, rather than detecting the extra screen size and resizing to fit.

The phone detects which apps suitable for this and enables extra in-game controls and launches the app in full-screen - however, it also flags apps not suitable for this and says they're "not optimised for fullscreen", which looks very negative/poor.

It looks like this used to work previously, as older GMS2 projects will be detected as games, marked as "suitable for fullscreen" on these devices, and will fill the full screen automatically. Whether this is a GMS2 change or an issue with using newer SDKs to build with now, we're still investigating.
Tagsandroid, Runner
1.4 Found In
2.x Runtime Found In2.2.0.261
2.x Runtime Verified In9.9.1.1431

Activities

Dan

2018-11-29 15:21

Adminstrator  

AirPlanPro.yyz (251,610 bytes)
bar test 2.yyz (14,844 bytes)

Dan

2018-11-29 17:37

Adminstrator   ~0062168

If you use the quicktest project I have now made you will see this launches with black bars and then after a few seconds the game receives a change of surface size to a new lower height, which then causes the application_surface to be scaled-down a second time, making the black bars thicker.

Dan

2018-11-29 17:38

Adminstrator  

quicktest.yyz (18,842 bytes)

Dan

2018-12-04 10:19

Adminstrator   ~0062173

Last edited: 2018-12-04 10:20

View 2 revisions

Reports that S8 clear the black borders (as we saw ourselves), but that S9 can at least in some circumstances fail to clear the borders and so show the previous app/home screen, etc., in those spaces. Screenshot attached.



S9NotClearingBorders.jpg (411,150 bytes)

Antanas Budvytis

2019-01-09 09:41

Developer   ~0062403

Cannot reproduce on S8, we need an S9 to test this properly.

Fritz

2019-04-24 12:10

Manager   ~0063711

Tested on S8 and apps are being listed as supporting full screen properly

No black bars seen with quicktest project, just a flash of splash screen