View Issue Details

IDProjectCategoryView StatusLast Update
00302652.x IDE BugsDebuggerPublic2019-01-31 14:11
ReporterDanAssigned ToAlexander Borup 
PriorityMediumSeverityB - MajorReproducibility<25%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.0 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030265: Debugger: Debugger layouts referencing desktops now found to be missing should be automatically reset
DescriptionDebugger layouts referencing desktops now found to be missing should be automatically reset, as otherwise users can find their debugger won't appear. We do log this out, so we know something is wrong, but we don't react to this error or present this information to the user. This is caused by the user tearing the debugger out to be its own IDE instance, moving this instance to a different monitor, adn the info for that monitor now being lost (e.g., a laptop temporarily docked, debugger moved to a second screen, now trying to use the laptop away from the dock).

You can see customers who have this issue when loading projects get this in their logs each time:
[06:10:10:323(bfb1)] Initialise(4.12)
[06:10:10:323(bfb1)] Debugger missing desktop 18

Expected: I would suggest it's safe to delete the debugger layout on this error, allowing GMS2 to immediately resolve the issue, but if required we could always show a dialog asking the user if they want the debugger layout to reset.

For any users affected by this, close GMS2, delete the two files C:\Users\[your pc username]\AppData\Roaming\GameMakerStudio2\[your gms2 username]\Cache\debug_layout.xml and C:\Users\[your pc username]\AppData\Roaming\GameMakerStudio2\[your gms2 username]\Layouts\gmdebug_layout.xml and restart GMS2. This will fix.
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/152059
TagsDebugger, IDE
2.x IDE Found In2.2.0.343
2.x Runtime Found In2.2.0.261
2.x IDE Verified In2.2.2.390
2.x Runtime Verified In2.2.2.302

Activities

Dan

2018-11-29 14:26

Adminstrator  

MissingDebugger.log (334,723 bytes)
MissingDebugger.PNG (655,733 bytes)