View Issue Details

IDProjectCategoryView StatusLast Update
0030263RunnerGeneralPublic2019-01-30 16:41
ReporterStewart BishopAssigned ToRussell Kay 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030263: General: Array Accessors work differently between 1D and 2D arrays
DescriptionWithin the sample project I make an array which has a nested array inside of it. I also make a 2D array with the same structure.

If I use the array accessor on the 1D nested array it will give me back a json with the nested array rather than the value at that position I'd expect.
If I use the array accessor on the 2D array, it'll give me back the value as expected.

The manual states no difference between using this array accessor on a 1D or 2D array so I'd expect the code in the sample to give 10 both times.
Steps To Reproduce1) Run the sample
TagsRunner
1.4 Found In
2.x Runtime Found In9.9.1.1263
2.x Runtime Verified In2.2.2.302

Activities

Stewart Bishop

2018-11-29 11:17

Adminstrator  

ArrayAccessorTest.yyz (23,165 bytes)

Mike Dailly

2018-11-29 14:20

Developer   ~0062165

a = 0;
a = ["Hello", "50Hello", "8.73Hello", [10, 50], [4.99, 8.73]];

// using 2D access on a 1D array should fail.
var t = a[@ 3, 0];


// var t = a[3, 0] DOES fail...

Russell Kay

2018-12-10 21:57

Manager   ~0062211

Stewart's issue is not a bug...

Mikes issue has been fixed.