View Issue Details

IDProjectCategoryView StatusLast Update
0030259RunnerWindowsPublic2019-01-31 10:18
ReporterDanAssigned ToMike Rennie 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10OS VersionPro x64
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030259: Windows: Games using vsync timing can see the debug overlay FPS value drop when the game loses focus
DescriptionWe're getting a couple of reports that Windows games using vsync timing will see the debug overlay FPS value drop when the game loses focus - the reports are actually that the games are visibly dropping to 30 FPS when they should be 60 FPS, but I am not reproducing this, so I suspect that's specific to certain GPU and high/variable refresh monitor combinations.

However, the debug overlay issue definitely reproduces. It only reproduces for me when the game speed is at 60, because this is my monitor's refresh rate. It is actually dropping to vsync, which makes sense, but if this is required and correct, then we need to better communicate what the overlay is showing and why this is not a performance drop for players.

Expected: We standardise fps_real and the value shown next to the debug overlay, as these values never match up - old timing method or new.
Steps To Reproduce1. Run the attached sample on Windows on a 60hz monitor.
2. Click off the game window and wait for a few seconds (sometimes it's immediately, but typically about 5 seconds or so).
3. Observe that the fps value shown next to the overlay bars will drop to 60.
4. Click on the game again and notice this does not "fix" the debug overlay fps.
5. Press F to toggle fullscreen and observe this "fixes" the bar.
Repro: 100%
Additional InformationF = fullscreen, S = cycle through different gamespeed_fps values, T = toggle the timing method.
Tagsgraphics, Runner
1.4 Found In
2.x Runtime Found In2.2.1.284
2.x Runtime Verified In2.2.2.302

Activities

Dan

2018-11-28 18:03

Adminstrator  

testfullscreenfps.yyz (24,177 bytes)

Mike Rennie

2018-12-17 17:20

Developer   ~0062283

Fixed by drawing fps_real in the debug overlay.