View Issue Details

IDProjectCategoryView StatusLast Update
0030256RunnerGeneralPublic2019-01-30 16:33
ReporterStewart BishopAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030256: General: Strings containing numbers at the start aren't converted to numbers
DescriptionWhen writing tests I've noticed that if you do something like:

var test = 10 < "50Hello";

This doesn't return true when apparently it should since Russell was saying that we'll parse the first character, see if it's a number and keep going until it's not a number then convert that as required.
Steps To Reproduce1) Create a project
2) Add the above to the room creation code
3) Run it
4) See that this if false rather than true
TagsRunner
1.4 Found In
2.x Runtime Found In9.9.1.1258
2.x Runtime Verified In2.2.2.302

Activities

Russell Kay

2018-11-29 14:19

Manager   ~0062162

Fixed in gitlab