View Issue Details

IDProjectCategoryView StatusLast Update
00302452.x IDE BugsGeneralPublic2019-05-24 11:58
ReporterDanAssigned ToDavid Clarke 
PriorityVery HighSeverityA - Crash/HangReproducibility<25%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.1 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030245: General: Startup sequences need further protection to avoid Windows IDE crashes and better inform users of issues
DescriptionWe're still seeing a number of tickets for crashes on startup, commonly around failure to download runtimes or write the runtime files to disk, but also for GPU issues and CEF incompatibility with the host machine. We need to find a better way to catch these issues safely, avoiding the GMS2 crash dialogs and instead giving users as much information as possible on how to diagnose and resolve their issue.

Attached are a number of logs and Helpdesk tickets containing details for the following startup crashes:

Crash on the splash screen whilst "Installing runtimes..." is shown.
Crash on splash screen or when first showing the Start Page during the first run after installing an IDE update.
Opening one or more secondary IDE instances via File > New IDE when working in an existing GMS2 instance.
Crashes due to the software renderer being required because the GPU cannot support GMS2.
Crashes due to CEF not being able to initialise properly due to some external software/policy on the PC.

Stalling with no crash message on the splash screen when "Installing custom languages..." is shown - ui.log contains no errors, just has the last line as "LoadingState: UserLogin" each time (screenshot for this one attached). No ui_crash.log is written, and you can actually still close GMS2 via the Windows X on the titlebar.
Steps To ReproduceDepends on the system GMS2 is being run on, and even for many of these reports the issue is intermittent, so no 100% repro rate, but the only step is to simply run GMS2.
TagsGM2KI
2.x IDE Found In2.2.0.343
2.x Runtime Found In2.2.0.261
2.x IDE Verified In2.2.3.417
2.x Runtime Verified In2.2.3.332

Activities

Dan

2018-11-27 11:00

Adminstrator  

221UIAfterUpdate.log (785,596 bytes)
221CrashAfterUpdate.log (88,772 bytes)

Dan

2018-11-29 12:03

Adminstrator  

StartupStalled.png (178,652 bytes)
StartupStalled.png (178,652 bytes)

Dan

2018-11-29 12:15

Adminstrator   ~0062160

Realised that the stall does actually output some further text once GMS2 is closed:

[12:05:57:652(f6fb)] ResourceManager resources have been cleared
[12:05:57:724(f6fb)] ####################################
[12:05:57:724(f6fb)] Break in Could not find a part of the path 'C:\Program Files\GMS2\user_directory\runlog.enc.new'. ( user_directory\runlog.enc ) (FileSystem_Local:630)
[12:05:57:725(f6fb)] ####################################
[12:05:57:725(f6fb)] File exception 'Could not find a part of the path 'C:\Program Files\GMS2\user_directory\runlog.enc.new'.'
[12:05:57:725(f6fb)] Failed to write user_directory\runlog.enc : Could not find a part of the path 'C:\Program Files\GMS2\user_directory\runlog.enc.new'. ( user_directory\runlog.enc )

Dan

2019-01-24 09:33

Adminstrator  

Dan-Jan24-ui_crash.log (155,565 bytes)
Dan-Jan24-ui.log (528,469 bytes)

Matthew McInnes

2019-04-05 09:51

Adminstrator   ~0063588

2.2.2:

https://yoyogames.zendesk.com/agent/tickets/156579

Alexander Borup

2019-05-10 14:31

Developer   ~0063893

We should see substantially fewer native exceptions on Windows on launch, following the fix for 0030271

Dan

2019-05-20 16:13

Adminstrator   ~0063950

We have made a number of startup crash fixes in other reports already, plus the memory corruption issue mentioned in the last comment, so we are already seeing internal versions are far more stable now. However, we have also added the new crash-reporting tool, which will now allow us to better capture crash info from all of our Windows IDE users and get these issues fixed much more quickly and confidently.

Resolving as "Fixed" and we will see what the feedback is during the beta period and continue to act on further reports of startup crashes as individual new bugs.