View Issue Details

IDProjectCategoryView StatusLast Update
00302412.x IDE BugsRemote WorkerPublic2019-01-29 14:49
ReporterSteven CampbellAssigned ToSteven Campbell 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSmacOSOS Version
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030241: Remote Worker: [Mac IDE] Stopping a remote Windows build does not work
DescriptionIn relation to 0030221 if you stop a build/run, it will complain about a runtimePath.
Steps To ReproduceSetup a Remote Worker on a Windows machine.
Attempt to build/run on the Windows machine from a Mac.
See that it complains about a runtimePath and does nothing.
Additional InformationManually calling Igor with the correct arguments does in fact work, so it's a simple IDE change.
TagsIDE, RemoteWorker
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.2.387
2.x Runtime Verified In2.2.2.302

Relationships

related to 0030221 ClosedSteven Campbell Remote Worker: [Mac IDE] Error upon building for Windows 
related to 0030244 AssignedSteven Campbell Remote Worker: [Mac IDE] Cannot cleanly stop an in-progress remote worker 

Activities

Steven Campbell

2018-11-27 10:36

Manager   ~0062145

Fixed in Red IDE/GitHub Pull Request 4371
Git Id: 659f9649dd1c8b66e4e29d53a0aa7886320152ce

Note this will stop a *running* build, but will not cleanly stop an *in-progress* build - see 0030244 for that, which is more involved due to spawning of additional untracked processes.

Matthew McInnes

2019-01-29 14:49

Adminstrator   ~0062553

Closing.Verified as fixed in:

IDE v2.2.2.387 Runtime v2.2.2.302