View Issue Details

IDProjectCategoryView StatusLast Update
0030206RunnerHTML5Public2019-01-31 09:47
ReporterStewart BishopAssigned ToMike Dailly 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.2.0 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030206: HTML5: Alarm within specific project never seems to get fired, because it's created with a decimal value
DescriptionThe user is using an alarm to make a typewriter style effect, this works as expected on Windows but in HTML5 the alarm is never fired.
Steps To Reproduce1) Run the sample on HTML5
2) Click
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.1.277
2.x Runtime Verified In2.2.2.302

Activities

Stewart Bishop

2018-11-12 17:24

Developer  

Typewriter HTML5 Bug.yyz (177,497 bytes)

Mike Dailly

2018-11-13 12:14

Developer   ~0062037

Sample code writes 0.6 to an alarm. This should be floored to 0, but on native is being delphi rounded.

*** Alarms are INTs, and values written to them should be FLOOR'd, not ROUND'd ***
Native now FLOORs values written to alarms.

Sample should be writing whole numbers (1 and above) to the alarm.