View Issue Details

IDProjectCategoryView StatusLast Update
0030204RunnerHTML5Public2019-05-13 17:35
ReporterStewart BishopAssigned ToMike Dailly 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.2.1 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030204: HTML5: keyboard_string and keyboard_lastchar translate key presses as if the keyboard in use was a UK keyboard
DescriptionUnder HTML5, the built-in variables keyboard_string and keyboard_lastchar translate key presses as if the keyboard in use was a UK keyboard.

For instance, on my US keyboard Shift-2 would produce @ but instead I get ". There are number of inconsistencies like this that point to this US keyboard acting like a UK keyboard.

Chrome, Firefox, and Edge all act the same.
Internet Explorer 11 works as expected.
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.1.277
2.x Runtime Verified In9.9.1.1437

Activities

Stewart Bishop

2018-11-12 17:07

Adminstrator  

keyboard_string.yyz (20,060 bytes)

Mike Dailly

2018-11-13 11:37

Developer   ~0062036

This is working as expected. However, you will need the correct language+region packs installed along with the correct keyboard installed and active. Installing both a US and UK region packs I was able to swap between them using the taskbar's language settings, and once this is done the keyboard input in the test app works as expected.

I suspect that browsers use the current language setting to help determine keyboards etc. We can only pass on what the browser tells us in these cases I'm afraid.

Stewart Bishop

2018-11-14 10:32

Adminstrator   ~0062041

Turns out this only happens when the code is obfuscated so we're reopening this.

Mike Dailly

2018-11-14 10:55

Developer   ~0062042

Fixed the obfuscation of the "key" inside the keydown event. Should now work as designed.

Dan

2018-11-26 15:02

Adminstrator   ~0062140

Fix is in runtime 282+.