View Issue Details

IDProjectCategoryView StatusLast Update
0030199RunnerAudioPublic2018-12-06 09:35
ReporterStewart BishopAssigned ToSteven Campbell 
PriorityVery HighSeverityA - Crash/HangReproducibility100%
Status ResolvedResolutionFixed 
Product Version2.2.0 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030199: Audio: Specific project crashes due to audio emitters
DescriptionWithin this users project, if you load an audio group then change to another, the game will crash as it tries to release the emitters and create new ones for the audio group just loaded.
Steps To Reproduce1) Run the sample
2) Click Control Group
3) Click 2
4) App crashes
Tagsaudio, Runner
1.4 Found In
2.x Runtime Found In
2.x Runtime Verified In

Activities

Steven Campbell

2018-11-26 14:26

Developer   ~0062139

Fixed in Red Runner/GitLab Merge Request 1011
Git Id: e76be798231391a490d291f1ad5a4e90f048282c

I could not get it to crash anywhere near the emitter code as the bug seems to state, but I got it to crash very regularly within the debug draw code, due to picking up a source that had had a buffer deleted ( but not nulled ) and therefore pointing at random memory. The fix checks the source against the currently playing noises, so that it only attempts to read it if it's actually active.