View Issue Details

IDProjectCategoryView StatusLast Update
0030193RunnerHTML5Public2019-01-31 09:52
ReporterStewart BishopAssigned ToMike Dailly 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.1.5 
Target Version2.2.2Fixed in Version2.2.2 
Summary0030193: HTML5: iOS Safari fails to pass a vec4 uniform value to shaders using shader_set_uniform_f, works with array variant
DescriptionI've found a case that shader_set_uniform_f failed to pass a vec4 uniform value to my shaders on html5 export, viewed with iOS safari. Using shader_set_uniform_f_array renders intended results.
Steps To Reproduce1) Run the sample on HTML5
2) Browse to it on an iOS device
3) See the issue
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.5.246
2.x Runtime Verified In2.2.2.302

Activities

Stewart Bishop

2018-11-12 15:47

Developer  

shader_bug.yyz (19,735 bytes)

Mike Dailly

2018-11-12 16:38

Developer   ~0062020

fixed on branch.