View Issue Details

IDProjectCategoryView StatusLast Update
00301672.x IDE BugsImporting ProjectsPublic2019-10-09 16:02
ReporterDanAssigned ToSteven Campbell 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.1.5 
Target Version2.2.4Fixed in Version2.2.4 
Summary0030167: Importing Projects (1.4): Sounds don't retain their quality settings
Description1.4 projects don't retain their audio quality settings on import, as GMS2 resets/misses them out entirely. This means it's easy for a user to build their game and wonder why the output package has grown considerably, or why sounds worse, etc. It's also obviously wrong that the previous information was ignored/lost.

Note that the default bitrate for a new sound in GMS2 is 128k and in 1.4 it's 192k, and GMS2 does not offer some of the very high sample rate values 1.4 claimed to offer - this is correct/by design.

Expected: The import values are exactly as they were set in the 1.4 project. Any values which *have* to change (e.g., super-high sample rates) should be called out in the compatibility report.
Steps To Reproduce1. Import the attached .yyz.
2. Observe that for all 3 sounds the bitrate has been raised/lowered to the GMS2 default of 128 and the Sample Rate value has been lost entirely, as it's lower than GMS2 now offers.

Repro: 100%
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/147885
TagsNo tags attached.
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.4.459
2.x Runtime Verified In2.2.4.366

Activities

Dan

2018-11-05 16:54

Adminstrator  

Project3.gmz (948,692 bytes)

Dan

2019-09-26 10:20

Adminstrator   ~0064849

Still occurs in 2.2.4 - all values appear to be reset to GMS2 defaults now.

Steven Campbell

2019-09-30 11:51

Manager   ~0064882

Fixed in Red IDE/GitHub Pull Request 4919
Git Id: fb2ed6abe39be5abf3c355a90cf5c46b3517804d

What was specifically missing was copying over bitRate and a 5512 sample rate which 1.x supported and 2.x did not

Steven Campbell

2019-09-30 11:55

Manager  

audio_test.gmz (10,578 bytes)

Scott Dunbar

2019-10-09 16:02

Adminstrator   ~0064951

Verified fixed