View Issue Details

IDProjectCategoryView StatusLast Update
00301502.x IDE BugsImporting ProjectsPublic2021-04-20 14:48
ReporterDanAssigned ToCoreTech 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionDuplicate 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.0 
Target VersionFixed in Version 
Summary0030150: Importing Projects (1.4): GMS2 ignores the "Game ID" 1.4 projects have and this information is lost during import
DescriptionGMS2 ignores the old "Game ID" 1.4 projects have and so this information is lost during import. However, some games rely on this game_id being set in order to verify save systems, etc.

Expected: Even if the value is not relevant for GMS2 projects, and so we don't need to add UI in for this, etc., it should be maintained as part of the import process so a game can still refer to the old value in code.
Steps To Reproduce1. Start GMS2 and import the attached sample.
2. RUn it for any target and observe the value on the second line is 0 (note that you did not get a compiler error because this value is not used in GMS2...).
3. Grep the project folder and observe "855514418" is only found in the display string within the object, when you would expect it to be in the .yyp also.
Repro: 100%
Additional Information IDE v2.2.1.360 Runtime v2.2.1.272
TagsNo tags attached.
2.x IDE Found In2.2.0.343
2.x Runtime Found In2.2.0.261
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2018-10-31 10:40

Adminstrator  

Project2.gmz (9,129 bytes)
Screenshot_11.png (3,676 bytes)
Screenshot_11.png (3,676 bytes)

Mike Dailly

2018-10-31 14:02

Developer   ~0061921

game saves in HTML5 come from game_id, which is no longer exposed, or exported. This means it's always 0.

I suspect it should use the new game GUID by default, but allow users to change it via a GML function call, so they can maintain compatibility with 1.x projects.

"GetLocalStorageRoot()" generates the name,
is made from: displayName + "." + g_pBuiltIn.game_id + ".";"

Alice

2021-04-20 14:48

Adminstrator   ~0065675

Moved the bug to Jira. Closing the bug. Thank you.