View Issue Details

IDProjectCategoryView StatusLast Update
00301452.x IDE BugsGeneralPublic2019-07-10 10:17
ReporterDanAssigned ToDan 
PriorityVery HighSeverityA - Crash/HangReproducibilityUnable To Reproduce
Status ResolvedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.0 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030145: General: Occasional Windows IDE startup crashes caused by Nvidia Optimus driver errors
DescriptionWe have a fair number of tickets for occasional startup crashes. Looking through the ui_crash.log files on these tickets, they all reference Nvidia's Optimus driver in the threads at the time of the crash. The issue doesn't seem to be 100% for these users, so isn't a blocker, but it does mean they see more crashes than other users. We need to look into what this Optimus driver does to GMS2 on initialisation.

Some users see the message "loadlibrary failed with error 1114" when getting this, but this seems to be fairly rare. Googling this error, many graphics applications have reported this issue for quite a while (since Windows 7) - the guidance is to put the GPU into high performance mode in its configuration panel.
TagsGM2KI
2.x IDE Found In2.2.0.343
2.x Runtime Found In2.2.0.261
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2018-11-27 11:25

Adminstrator   ~0062146

We're already seeing a noticeable drop-off in these tickets, so it looked like it was a bad driver version put out and already fixed by Nvidia. Will continue to monitor for a bit, but really anything we can do to mitigate this happening again on our end should still be done.

Dan

2019-01-03 13:40

Adminstrator   ~0062336

Do still get the occasional ticket for this. The advice remains to perform a GPU driver update at your earliest convenience.

Dan

2019-04-01 15:27

Adminstrator   ~0063567

We have another wave of this at the moment - a few users reporting even the new 419.67 driver fails to stop the issue for them. Will need to ensure this is handled by the crash logging stuff for 2.2.3, so we can gather reports.

Dan

2019-06-25 14:39

Adminstrator   ~0064277

We have not so far had anyone report this with 2.2.3 - it *might* be that the memory fix resolved this also.

Dan

2019-07-10 10:17

Adminstrator   ~0064386

Resolving as Fixed, as we have gone the entire beta period and a week of full release, and no Optimus reports since.

Obviously, the ui_crash.log file is gone in 2.2.3, so reports would be different anyway.