View Issue Details

IDProjectCategoryView StatusLast Update
00301262.x IDE BugsPreferencesPublic2019-01-04 16:46
ReporterDanAssigned ToSteven Campbell 
PriorityLowSeverityD - MinorReproducibility100%
Status ClosedResolutionFixed 
Platform-OSmacOS SierraOS Version10.12.3
Product VersionInternal Build 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030126: Preferences: Spacing for the EULA URL on Beta page is not "clever"
DescriptionThe green EULA URL on the "Beta" page of Preferences is squashed if using the Mac IDE and 4K+, so it's always wrapping badly. Windows IDE 4K does not reproduce.

Also, on both Windows and Mac IDE, if you resize the window to make it smaller the URL does not wrap properly, when the paragraph text on that page does.
Steps To Reproduce1. Start the IDE.
2. File > Preferences > Beta
3. Make the Preferences window smaller.
4. Observe the URL does not wrap and is quickly lost.
Repro: 100%

1. Start the Mac IDE on qa4kimac or Matthew's 5k iMac (for example - I'm sure there are others in the office with at least 4K Macs).
2. File > Preferences > Beta
3. Observe the EULA link is wrapping already even though there is space on-screen.
Repro: 100%
TagsNo tags attached.
2.x IDE Found In2.2.1.353
2.x Runtime Found In2.2.1.266
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2018-10-23 16:30

Adminstrator  

Dan

2018-10-24 09:51

Adminstrator   ~0061832

See if we can make the words "E U L A" the link

Steven Campbell

2018-10-24 13:58

Manager   ~0061844

Fixed in Red IDE/GitHub Pull Request: 4327
Git Id: 3702508bc11e7cd0ab7484594936304bc766c86a

Dan

2018-10-26 09:29

Adminstrator   ~0061863

Mac IDE still needlessly wraps that URL.

Steven Campbell

2018-11-13 09:34

Manager   ~0062031

Think this was due to a missing dpi_px

Steven Campbell

2018-11-15 14:41

Manager   ~0062060

Another fix in Red IDE/GitHub Pull Request 4353
Git Id: 29e5c7af8e1c8c4bfb1a38be5faac1c01e44920c

Dan

2018-11-16 11:22

Adminstrator   ~0062074

Fix is in 2.2.1.367+

Dan

2018-11-16 16:08

Adminstrator   ~0062089

All good in IDE v2.2.1.367 Runtime v2.2.1.278. Closing.