View Issue Details

IDProjectCategoryView StatusLast Update
00300872.x IDE BugsBuild AndroidPublic2018-10-31 09:27
ReporterStewart BishopAssigned ToRussell Kay 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformAndroidOSOS Version
Product Version2.2.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030087: Build Android: Unable to build for YYC using new build system on Windows 7 machines
DescriptionWithin the newest release you're unable to build for Android YYC using the latest build system on Windows 7 as you'll receive the following error:

make: *** create_child_process: DuplicateHandle(In) failed (e=6)

Looking online there's a page which states they have the same error https://stackoverflow.com/questions/23873207/android-ndk-build-error-make-exe-create-child-process-duplicatehandlein and it turns out you can fix it by using a batch file instead of starting a process automatically.
Steps To Reproduce1) Open GMS2 on a Windows 7 machine
2) Run any project on Android YYC
3) See that this fails due to the above error
TagsNo tags attached.
2.x IDE Found In2.2.0.343
2.x Runtime Found In2.2.0.261
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Russell Kay

2018-10-22 16:24

Manager   ~0061825

Fixed in gitlab - still trying to get to a point I can test this but this commit should work

Dan

2018-10-24 14:00

Adminstrator   ~0061847

Fix is now in green

Stewart Bishop

2018-10-25 10:40

Adminstrator   ~0061856

Reopening as this doesn't actually work.

C:\Users\Stewart>cmd.exe /c "C:\Android\ndk-bundle\ndk-build.cmd APP_STL=c++_sha
red APP_PLATFORM=android-14 APP_ABI="armeabi-v7a arm64-v8a " -j 2 NDK_LIBS_OUT="
Y:/Test_118D9429_YYC/lib" "
Android NDK: Could not find application project directory !
Android NDK: Please define the NDK_PROJECT_PATH variable to point to it.
C:\Android\ndk-bundle\build\\..\build\core\build-local.mk:151: *** Android NDK:
Aborting . Stop.

Russell Kay

2018-10-26 15:05

Manager   ~0061872

Fixed in gitlab (again)